EXCEL-BEISPIELE        GÜLTIGKEITSKRITERIEN in STAR-CALC


GÜLTIGKEITSPRÜFUNG

Zur Vermeidung "falscher" Einträge in eine Zelle oder Tabelle bietet EXCEL die Möglichkeit einer Eingabebe-schränkung. Mit der Gültigkeitsprüfung können wir festlegen, welche Daten in welchen Zellen zugelassen sind.

In den Buchhandlungen von KUMMER & SORGE müssen zwischen 15. April und 15. Mai auf Wunsch der Marketing-Abteilung an den Kassen Informationen erfasst (teilweise ist eine Befragung der Käufer erforderlich) und in diese Tabelle eingegeben werden:

 

Käuferanalyse
Datum Betrag Warengruppe Ust-Satz Kunde Geschlecht Land Kaufzweck
             

 

Damit in der Hektik des Kassiervorganges falsche Eingaben unterbleiben, werden wir EXCEL die Eingaben prüfen lassen, Drop-down-Felder zur Verfügung stellen oder automatisieren.
1. Die Spalte Datum
  • Cursor in Zelle A3
  • Daten / Gültigkeit (abgebildete Einstellungen vornehmen)

Einstellungen für die Gültigkeitsprüfung

 

Nach der Eingabe 16. 4 steht in A3 16. April.
Bei einem Tippfehler - z. B. 4. 16 - erscheint eine Fehlermeldung:

Fehlermeldung bei Eingabe falscher Gültigkeitswerte

 

  • Damit sich der Anwender besser zurecht findet veranlassen wir bei der Gültigkeitsprüfung eine informativere Fehlermeldung:

Erklärender Text bei nicht bestandener Gültigkeitsprüfung

 

2. Die Spalte Betrag
  • In B3 lassen wir die Eintragungen mit Hilfe eines Drop-down-Feldes vornehmen:

 

3. Die Spalte Warengruppe
  • Erzeugen Sie C3 ein Drop-down-Feld, das die Wahl zwischen Buch, Zeitschrift, Papier und Software ermöglicht
4. Die Spalte USt-Satz
  • D3 mit "Prozent" ohne Dezimalstellen formatieren
  • Mit einer WENN-Formel erreichen wir den automatischen Eintrag des USt-Satzes: =WENN(C3="Buch";10%;WENN(C3="Zeitschrift";10%;20%))
5. Die Spalte Kunde
  • in Zelle E3 sorgen wir für diese Einstellungen (linkes Bild unten)
  • und eine Eingabemeldung, die dem Anwender eine Information über den gewünschten Eintrag gibt (rechtes Bild unten)

Gültigkeitsprüfung: festlegen der Textlänge    

    

  • Erzeugen Sie eine Fehlermeldung mit dem Text Bitte "neu" oder "alt" eingeben, wenn in E3 keine oder eine falsche Eingabe erfolgt.
6. Die Spalte Geschlecht
  • nach dem Muster von E3 lassen Sie in F3 nur w oder m als Einträge zu
  • verfassen Sie eine passende Eingabemeldung
  • und eine Fehlermeldung
7. Die Spalte Land
  • Erzeugen Sie G3 ein Drop-down-Feld, das die Wahl zwischen Wien, , B und Ausland ermöglicht
8. Die Spalte Kaufzweck
  • versehen Sie ebenfalls mit einem Drop-down-Menü, die Wahlmöglichkeiten sind: Geschenk, Eigenbedarf, Anderes

Testen Sie Ihre Tabelle mit verschiedenen Datensätzen!

 

Käuferanalyse

Datum Betrag Warengruppe Ust-Satz Kunde Geschlecht Land Kaufzweck
15.4 >50€ Software 20% neu m Geschenk
17.4 bis 10€ Papier 20% alt w Wien Anderes
17.4 21-50€ Buch 10% alt w Wien Geschenk

EXCEL-BEISPIELE        GÜLTIGKEITSKRITERIEN in STAR-CALC