EXCEL-INHALT        WENN-ODER-Beispiele mit STAROFFICE-CALC    WENN-ODER mit EXCEL 2007

 

WENN-ODER Funktion

Die WENN-UND-Bedingung liefert ein bestimmtes Ergebnis nur dann, wenn zwei Voraussetzungen zutreffen.

Im Gegensatz dazu liefert die WENN-ODER-Bedingung ein bestimmtes Ergebnis, wenn eine von zwei möglichen Voraussetzungen zutrifft. Beim ersten Beispiel heißt das entweder mehr als drei Kinder ODER mehr als sechs Bewohner.

Beispiel 1:

  • In der Spalte Familie soll GROSS stehen, wenn es mehr als 3 Kinder oder mehr als 6 Bewohner gibt. Andernfalls bleibt das Feld leer
  • Wer weniger als 20.000 €/Jahr verdient und mindestens 2 Kinder hat, erhält pro Kind 500.- € Beihilfe. Berechne die Gesamtbeihilfe für jede Familie

 

  A B C D E F
1 W o h n e n
2

Name

€/Jahr

Kinder

Beihilfe Bewohner Familie
3 Schmid 19.290 2  

4

 
4 Kreiner 63.800 5   7  
5 Loos 19.600 1   3  
6 Jason 42.450 3   6  
7 Braun 24.980 4   6  

 

Diese Formeln liefern die Lösungen:
In F3 steht  =WENN(ODER(C3>3;E3>6);"GROSS";" ")
In D3 steht  =WENN(UND(B3<20000;C3>1);500*C3;0)

Ergebnis:

  A B C D E F
1 W o h n e n
2

Name

€/Jahr

Kinder

Beihilfe Bewohner Familie
3 Schmid 19.290 2 1000

4

 
4 Kreiner 63.800 5 0 7 GROSS
5 Loos 19.600 1 0 3  
6 Jason 42.450 3 0 6  
7 Braun 24.980 4 0 6

GROSS

 

Beispiel 2:
  • Wer schneller als 13,5 Sekunden läuft oder höher als 1,5 m springt, dessen Leistung ist GUT
  • Wer jünger als 18 Jahre ist und die 100 m unter 12 Sekunden läuft, wird gefördert

 

  A B C D E F
1

Leichtathletik

2

Name

100m

Hoch

Alter Leistung Fördern
3 Susanne 13,2 1,45 14    
4 Georg 13,4 1,43 13    
5 Hannes 12,3 1,68 16    
6 Stefan 11,7 1,79 16    
7 Claudia 12,8 1,55 17    
8 Erwin 13,8 1,46 18    
9 Willi 11,9 1,85 17    
10 Sylvia 13,9 1,41 13    

 

Lösung - Beispiel 2:

in E3 steht  =WENN(ODER(B3<13,5;C3>1,5);"GUT";" ")

in F3 steht  =WENN(UND(D3<18;B3<12);"JA";" ")

EXCEL-INHALT        WENN-ODER-Beispiele mit STAROFFICE-CALC    WENN-ODER mit EXCEL 2007