KUMMER+SORGE    EXCEL-ANWENDUNGEN    GESETZL. RECHNUNGSBESTANDTEILE    FORMULAR+DIALOGFELD    LAGERSTAND AKTUALISIEREN

VERKNÜPFTES RECHNUNGSFORMULAR

MIT AUTOMATISCHEN EINTRÄGEN

 

Für die Übungsfirma entwickeln wir in EXCEL ein Rechnungsformular, in das wir die Kundenadressen und die Artikel-Daten nicht mühsam von Hand, sondern vom Programm einsetzen lassen. Speichern Sie die Datei unter dem Namen: KUSO-Auftragsabwicklung
Zuerst gestalten wir das Formular:

 

A B C D E F G
1

kummer + sorge   buchhandel + verlag

2              
3              
4              
5        

RECHNUNG

 
6         Nummer:    
7         Datum:    
8         KundenNr.:    
9         Gebiet:    
10              
11              
12              
13              
14              
15 Bezug: Lieferschein  46/TT.MM.JJ Bearbeiter: Frau .......  
16 Versandart: Zustellung   UID: ATU 24683571
17 Lieferbedingung: frei Haus   MwSt.: 10%  
18              
19              
20 Lieferung vom: Datum   Ihr Betreuer:      
21              
22              
23 ArtikelNr ISBN Bezeichnung Autor Stück EZ-Preis Gesamtpreis
24              
25              
26              
27              
28              
29              
30              
31              
32              
33              
34           Netto  
35           MwSt  
36           Endsumme  
37              
38              
39 KUMMER + SORGE, 1070 Wien, Kaiserstraße 25  Tel.: 01/523 1314
40 http://www.kuso.at   E-Mail: abc@kuso.at   FN: 67491 / HG Wien
41              
42 Es gelten unsere allgemeinen Geschäftsbedingungen. Gerichtsstand ist Wien.  
43 Bankverbindung: Bank-Austria-Creditanstalt 0531-26300-00, BLZ 11000  
44              

 

In Tabelle2 unserer EXCEL-Datei legen wir die Datenbank für unsere Kunden an. Die Tabelle kann einfach aus dem Kapitel Fachpraktikum / Kunden kopiert werden. Nicht benötigte Spalten löschen. Tabelle2 auf Kunden umbenennen!
So sieht der erste Teil der benötigten Tabelle (insgesamt 25 Kunden) aus:

 

KdNr Name Gebiet PLZ Ort Straße Sex Ansprechpartner
1-028 Bücher-Goldnagl WNB 1150 Wien Ziegelhofstraße 36 w Nicole Goldnagl
1-043 Kopfnuß WNB 1010 Wien Bankgasse 1 w Barbara Ernsthofer
1-187 Liesmich WNB 1030 Wien Beatrixgasse 6 m Angelo Reiter
1-254 Wiesinger KG WNB 1140 Wien Linzer Straße 456 m Michael Wiesinger
2-088 Grenzbuch WNB 2421 Kittsee Eisnergasse 15 m Mario Waldherr

 

In F8 des Rechnungsformulars wird die KundenNr. eingetragen.
Unter Verwendung dieses Eintrags soll die Funktion SVERWEIS in A6 den Firmennamen, in A7 die Straße, in A8 die Postleitzahl und in B8 den Ort einsetzen.
Wenn wir in F8 die Nummer 9-219 eingeben und in 
A6 die Formel =SVERWEIS(F8;Kunden!$A$2:$H$26;2), dann wird dort automatisch der Firmenname, in diesem Fall also Kiosk-Janschitz, eingefügt.
Die Straße in A7 wird mit =SVERWEIS(F8;Kunden!$A$2:$H$26;6),
die Postleitzahl in A8 mit =SVERWEIS(F8;Kunden!$A$2:$H$26;4) und
der Ort in B8 mit =SVERWEIS(F8;Kunden!$A$2:$H$26;5) in das Anschriftsfeld eingesetzt.
In E20 lassen wir mit der Formel =WENN(F9="WNB";"Flacher";WENN(F9="SO";"Zadnik";WENN(F9="KSt";"Arthaber";"Inführ")))     den Namen des Gebietsbetreuers eintragen.

 

In Tabelle3 unserer EXCEL-Datei legen wir die Datenbank für die Artikel an. Auch diese Tabelle kann aus dem Kapitel Fachpraktikum / Artikel kopiert werden. Nicht benötigte Spalten löschen. Tabelle3 auf Artikel umbenennen!
So sieht der Beginn der benötigten Tabelle (insgesamt 657 Artikel) aus:

 

ArtikelNr ISBN Artikelbezeichnung Autor Preis Lagerstand
1 3-423-10759-6 Flinke Killer Bukowski, Charles € 10,54 40
2 3-423-12578-0 Gedichte die einer ... Bukowski, Charles € 6,83 50
3 3-596-10678-8 Fuck Machine Bukowski, Charles € 5,81 100
4 3-596-10680-X Kaputt in Hollywood Bukowski, Charles € 5,81 40
5 3-518-36682-3 Siddharta Hesse, Hermann € 6,10 60
6 3-518-36675-0 Der Steppenwolf Hesse, Hermann € 8,43 38
7 3-518-36579-7 Das Glasperlenspiel Hesse, Hermann € 12,94 50
8 3-499-12074-7 Portnoys Beschwerden Roth, Philip € 7,99 70

9

3-499-22310-4 Sabbaths Theater Roth, Philip € 10,54 25

 

Sobald eine ArtikelNr eingegeben wird, soll das Programm ISBN, Bezeichnung, Autor und Stückpreis im Formular ausgeben.
Für die ISBN lautet die Formel in B24 =WENN(A24=" ";" ";SVERWEIS(A24;Artikel!$A$2:$F$658;2)) - die Formel in Worten ausgedrückt: 
Wenn es in A24 keinen Eintrag (WENN(A24=" ";) gibt, bleibt B24 leer (" ";), ansonsten soll die zum Eintrag in A24 (SVERWEIS(A24;) in der Artikeltabelle (Artikel!) im Bereich von A2 bis F658 ($A$2:$F$658;) gehörende ISBN (steht in Spalte 2 2)) eingesetzt werden.
In C24 steht =WENN(A24="";"";SVERWEIS(A24;Artikel!$A$2:$F$61;3))
In D24 steht =WENN(A24="";"";SVERWEIS(A24;Artikel!$A$2:$F$61;4))
In F24 steht =WENN(A24="";"";SVERWEIS(A24;Artikel!$A$2:$F$61;5))
Alle Formeln aus Zeile 24 werden bis Zeile 33 kopiert.
Stückanzahl eintragen; Gesamtpreise sind zu berechnen.

 

So könnte eine Rechnung für die Firma "Bücher-Goldnagl" aussehen
A B C D E F G
1

kummer + sorge   buchhandel + verlag

2              
3              
4              
5        

RECHNUNG

 
6 Bücher - Goldnagl     Nummer: 31/Datum  
7 Ziegelhofstraße 36     Datum: TTMMJJ  
8 1150 Wien     KundenNr.: 1-028  
9         Gebiet: WNB  
10              
11              
12              
13              
14              
15 Bezug: Lieferschein  46/TTMMJJ Bearbeiter: Frau .......  
16 Versandart: Zustellung   UID: ATU 24683571
17 Lieferbedingung: frei Haus   MwSt.: 10%  
18              
19              
20 Lieferung vom: Datum   Ihr Betreuer: Hr. Flacher    
21              
22              
23 ArtikelNr ISBN Bezeichnung Autor Stück EZ-Preis Gesamtpreis
24 6 3-518-36675-0 Der Steppenwolf Hesse, Hermann 10 8,43

84,30

25 9 3-499-22310-4 Sabbaths Theater Roth, Philip 15 10,54 158,10
26 32 3-442-06938-6 Unter Büffeln Larson, Gary 5 4,51 22,55
27 48 3-257-22675-6 Der blaue Siphon Widmer, Urs 5 7,27 36,35
28 51 3-453-55004-8 Die Rothschilds Corti, Egon 2 6,18 12,36
29              
30              
31              
32              
33              
34           Netto 313,66
35           MwSt 31,37
36           Endsumme 345,03
37              
38              
39 KUMMER + SORGE, 1070 Wien, Kaiserstraße 25  Tel.: 01/523 1314
40 http://www.kuso.at   E-Mail: abc@kuso.at   FN: 67491 / HG Wien
41              
42 Es gelten unsere allgemeinen Geschäftsbedingungen. Gerichtsstand ist Wien.
43 Bankverbindung: Bank-Austria-Creditanstalt 0531-26300-00, BLZ 11000
44  

 

KUMMER+SORGE    EXCEL-ANWENDUNGEN    GESETZL. RECHNUNGSBESTANDTEILE    FORMULAR+DIALOGFELD    LAGERSTAND AKTUALISIEREN