CALC-INHALT    KKLEINSTE    KGRÖSSTE mit EXCEL   KKLEINSTE mit EXCEL    WENN    WENN-UND    WAHLEN

 

Verwendung der Funktion KGRÖSSTE
für die Berechnung der Mandatsgewinne bei einer NR-Wahl im 3. Ermittlungsverfahren (Werte der Wahl 2002)

  A B C D E F G H I J K L
1 gültige Stimmen ÖVP SPÖ FPÖ GRÜNE MANDATE   Wahlzahl Mand. ÖVP Mand. SPÖ Mand. FP Mand. GRÜ
2 4.909.645

2.076.833

1.792.499

491.328 464.980 1  

25.978

       
3           2            
4 4%-Klausel         3            
5 196.386         4            
6           5            
7 ÖVP         6            
8 2.076.833         7            
9           8            
10 SPÖ         9            

 

Der gesetzlichen Regelung für die Durchführung der NR-Wahlen in Ö folgend, sind die Formeln und Funktionen in der CALC-Tabelle eingerichtet.

A5: =A2*4%   Stimmen, die eine Partei mindestens erreichen muss
B2
: =WENN(A8>A5;A8;0)  WENN der ÖVP-Stimmenanteil A8 die in A5 berechnete 4%-Grenze übertrifft > wird der Wert aus A8 übernommen, andernfalls wird 0 eingesetzt
C2
: =WENN(A11>A5;A11;0)
D2: =WENN(A14>A5;A14;0)
E2: =WENN(A17>A5;A17;0)
B3
: =$B$2/F3         im 3. Ermittlungsverfahren ist die Stimmenzahl zuerst durch 2, darunter durch 3, 4, 5, ... zu teilen
C3: =$C$2/F3
D3: =$D$2/F3
E3: =$E$2/F3
Die Formeln in B3, C3, D3 und E3 werden nach unten kopiert und zwar so weit, bis der Wert der Wahlzahl unterschritten wird. Kann aber auch weiter sein, wenn es Ihnen gefällt. In diesem Beispiel ging es bis Zeile 90.

H2: =KGRÖSSTE(B2:E90;183) die 183-größte Zahl im Bereich von B2 bis E90 ist zu finden.
I2
:
  =WENN(UND($H$2<=B2;B2>A2*4%);"Mandat";" ")  WENN die Wahlzahl kleiner < oder gleich = groß als/wie die Zahl der erhaltenen Stimmen ist, UND die Zahl der Stimmen die 4%-Klausel erfüllt B2>A2*4%, soll das Wort Mandat "Mandat" ausgegeben werden, andernfalls soll die Zelle leer " " bleiben.
J2:
=WENN(UND($H$2<=C2;C2>A2*4%);"Mandat";" ")
K2:
=WENN(UND($H$2<=D2;D2>A2*4%);"Mandat";" ")
L2:
=WENN(UND($H$2<=E2;E2>A2*4%);"Mandat";" ")
I3:
  =WENN($H$2<=B3;"Mandat";" ") WENN die Wahlzahl kleiner < oder gleich = groß als/wie der Wert in B3 soll das Wort Mandat "Mandat" ausgegeben werden, andernfalls soll die Zelle leer " " bleiben.
J3:
=WENN($H$2<=C3;"Mandat";" ")
K3:
=WENN($H$2<=D3;"Mandat";" ")
L3:
=WENN($H$2<=E3;"Mandat";" ")
Die Formeln in I3, J3, K3 und L3 werden nach unten kopiert und zwar mindestens so weit, bis das Wort
Mandat nicht mehr eingefügt wird. Kann aber auch weiter sein, wenn es Ihnen gefällt. In diesem Beispiel ging es bis Zeile 89.

I90: =ZÄHLENWENN(I2:I89;"Mandat") Zwischen I2 und I 89 I2:I89 wird gezählt, wie oft der Begriff Mandat Mandat ausgegeben ist und das Ergebnis in I90 ZÄHLENWENN eingefügt.
J90:
=ZÄHLENWENN(J2:J89;"Mandat")
K90:
=ZÄHLENWENN(K2:K89;"Mandat")
L90:
=ZÄHLENWENN(L2:L89;"Mandat")

 

  A B C D E F G H I J K L
1 gültige Stimmen ÖVP SPÖ FPÖ GRÜNE MANDATE   Wahlzahl Mand. ÖVP Mand. SPÖ Mand. FP Mand. GRÜ
2 4.909.645

2.076.833

1.792.499

491.328 464.980 1  

25.978

Mandat Mandat Mandat Mandat
3   1.038.417 896.250 245.664 232.490 2     Mandat Mandat Mandat Mandat
4 4%-Klausel 692.278 597.500 163.776 154.993 3     Mandat Mandat Mandat Mandat
5 196.386 519.208 448.125 122.832 116.245 4     Mandat Mandat Mandat Mandat
6  

usw.

      5     usw.      
7 ÖVP         6            
8 2.076.833         7            
9           8            
10 SPÖ         9            
11 1.792.499         10            
12           11            
13 FPÖ         12            
14 491.328         13            
15           14            
16 GRÜNE         15            
17 464.980         16            
..           ..            
..           ..            
..           ..            
..           ..            
..           ..            
90           ..     79 69 18 17


Berechnen Sie die Mandatsgewinne bei der NR-Wahl 2006 bzw. 2008 analog der o. verwendeten Formeln
Ergebnisse 2006 
1.616.493  1.663.986  519.589  520.130  193.539  Gültige St. 4.708.281
Ergebnisse 2008  1.269.656  1.430.206  857.029  509.936  522.933  Gültige St. 4.887.309

  A B C D E   F G H I J K L  
1 gültige Stimmen ÖVP SPÖ FPÖ GRÜNE BZÖ MANDATE   Wahlzahl Mand. ÖVP Mand. SPÖ Mand. FP Mand. GRÜ Mand. BZÖ
2 4.708.281

 

 

   

 

1  

 

         
3             2              
4 4%-Klausel           3              
5 188.331           4              
6             5              
7 ÖVP           6              
8 1.616.493           7              
9             8              
10 SPÖ           9              

 

Die Funktion KKLEINSTE

Bei einem über drei Tage angesetzten Wettbewerb gab es am ersten Tag schon einige Ausfälle. Am zweiten Tag müssen die Teilnehmer mit dem Rad eine 265 km lange Strecke zurücklegen. Die Athleten starten einzeln, in Abständen von fünf Minuten. Daher gibt es keinen gemeinsamen Zieleinlauf und die Zeiten müssen gesondert ermittelt werden.
Nur die besten 30 qualifizieren für die Prüfung am letzten Tag.

 

  A B C D E
1 Nummer Zeit Limit Beurteilung  
2 2 7:32:20

7:10:10

   
3 3 7:56:13      
4 5 7:09:19   QUALIFIZIERT  
5 7 6:59:56   QUALIFIZIERT  
6 8 6:56:44   QUALIFIZIERT  
7 9 6:55:38   QUALIFIZIERT  
8 11 8:09:55      
9 12 6:57:29   QUALIFIZIERT  
10 13 7:24:30      
11 16 7:21:22      
12 17 7:31:56      
13 20 7:39:12      
14 23 7:07:59   QUALIFIZIERT  
15 24 7:12:50      
16 26 6:58:44   QUALIFIZIERT  
17 28 7:41:51      
18 29 7:50:02      
19 30 7:02:46   QUALIFIZIERT  
20 31 7:14:08      
21 32 7:49:32      
22 35 7:00:05   QUALIFIZIERT  
23 36 7:55:31      
24 37 7:00:34   QUALIFIZIERT  
25 38 7:38:19      
26 41 7:00:31   QUALIFIZIERT  
27 42 6:58:01   QUALIFIZIERT  
28 43 7:10:10   QUALIFIZIERT  
29 44 7:56:20      
30 46 7:09:44   QUALIFIZIERT  
31 47 6:56:01   QUALIFIZIERT  
32 48 6:59:55   QUALIFIZIERT  
33 49 7:01:41   QUALIFIZIERT  
34 50 7:09:08   QUALIFIZIERT  
35 52 6:56:41   QUALIFIZIERT  
36 53 7:51:46      
37 54 7:12:57      
38 55 7:48:37      
39 56 7:50:59      
40 61 6:57:00   QUALIFIZIERT  
41 62 7:23:52      
42 64 6:56:03   QUALIFIZIERT  
43 65 7:58:44      
44 66 7:03:57   QUALIFIZIERT  
45 67 7:00:32   QUALIFIZIERT  
46 68 7:51:33      
47 70 7:00:29   QUALIFIZIERT  
48 71 6:55:58   QUALIFIZIERT  
49 73 7:54:09      
50 74 7:19:50      
51 76 7:22:11      
52 78 7:07:23   QUALIFIZIERT  
53 80 7:39:08      
54 85 7:59:01      
55 86 7:01:05   QUALIFIZIERT  
56 87 7:11:09      
57 88 7:04:56   QUALIFIZIERT  
58 89 7:29:30      
59 91 6:55:48   QUALIFIZIERT  
60 92 7:09:39   QUALIFIZIERT  
61          

 

C2: =KKLEINSTE(B2:B60;30)  Die 30 besten Zeiten werden eruiert, von diesen die schlechteste wird in C2 gezeigt.
D2: =WENN(B2<=$C$2;"QUALIFIZIERT";" ")

 

CALC-INHALT    KGRÖSSTE mit EXCEL    KKLEINSTE mit EXCEL    WENN    WENN-UND    WAHLEN